This is a step by step guide on how to add support for Perforce version control system and enable team collaboration directly in WireframeSketcher. This is done by installing the P4Eclipse official Perforce Eclipse plug-in.

Installing

Follow these steps to install the Perforce plugin:

1. Open Help > Install New Software… wizard, and paste the following update site link into Work with field and press Enter. Wait for the software list to load and the Pending… message to disappear.
http://www.perforce.com/downloads/http/p4-eclipse/install/4.4

2. Check the Perforce SCM Support entry in the list

Perforce P4Eclipse plugin

3. Uncheck the option that says Contact all update sites during install to find required software and click Next

4. Click Next again, accept the license agreement and click Finish

5. When prompted for restart choose Yes

To learn how to use the P4Eclipse plugin follow the P4Eclipse Help which is also available directly in WireframeSketcher under Help > Help Contents > Perforce SCM.

Note that to connect to a Perforce server you’ll need to switch to Perforce perspective first using Window > Open Perspective > Other… > Perforce. To switch back to Wireframing perspective use Window > Open Perspective > Other… > Wireframing.

Uninstalling

To uninstall the Perforce plugin select Help > About WireframeSketcher > Installation Details then choose Perforce SCM Support and click Uninstall… and then Finish.