This is a step by step guide on how to add support for Git version control system and enable team collaboration directly in WireframeSketcher. This is done by installing EGit plugin which is provided freely by Eclipse platform.

Note that if WireframeSketcher is installed system-wide (which is usually the case on Linux) then you’ll need to run it as administrator. You may also opt to install WireframeSketcher for your user only (choose zip archive when installing on Linux).

Installing

Follow these steps to install the Git plugin:

1. Enable Eclipse Luna update site in WireframeSketcher’s preferences under Window > Preferences > Install/Update > Available Software Sites:

Enable Luna update site

Make sure that the Luna entry is checked.

2. Open Help > Install New Software… wizard, select Luna in Work with field and then wait for the software list to load and the Pending… message to disappear.

3. Type Git in the type filter text search field and wait for the software list to change

4. Check the Eclipse Git Team Provider entry in the list

Git plugin

5. Uncheck the option that says Contact all update sites during install to find required software and click Next

6. Click Next again, accept the license agreement and click Finish

7. Accept the security warning prompt and when prompted for restart choose Yes

To learn how to use the Git plugin read Git version control with Eclipse tutorial or go through the more extensive EGit User Guide which is also available directly in WireframeSketcher under Help > Help Contents > EGit Documentation.

Uninstalling

To uninstall the Git plugin select Help > About WireframeSketcher > Installation Details then choose Eclipse Git Team Provider and click Uninstall… and then Finish.