This is a step by step guide on how to add support for Subversion version control system and enable team collaboration directly in WireframeSketcher.

Note that if WireframeSketcher is installed system-wide (which is usually the case on Linux) then you’ll need to run it as administrator. You may also opt to install WireframeSketcher for your user only (choose zip archive when installing on Linux).

There are 2 similar plugins for Subversion that can be used with WireframeSketcher. The first one is called Subclipse and it’s developed by the same people that develop Subversion. The other one is called Subversive and it’s developed by Polarion. Both plugins are free and work well, however we recommend Subclipse as it’s easier to install and use. You can find installation instructions for both Subclipse and Subversive plugins below.

Subclipse plugin

Here are the steps that you need to follow to install Subclipse plugin:

1. First you’ll need to decide which what version of Subversion you’ll be working with. The latest version is 1.8.x, but you might have the older 1.7.x version. Depending on which version you need you’ll have to choose between these 2 update sites:

1.1. http://subclipse.tigris.org/update_1.10.x – for Subversion 1.8.x

1.2. http://subclipse.tigris.org/update_1.8.x – for Subversion 1.7.x

2. Open Help > Install New Software… wizard, and paste one of the above links into Work with field and press Enter. Wait for the software list to load and the Pending… message to disappear.

3. Check the Subclipse, Subversion Client Adapter, SVNKit Client Adapter and SVNKit Library entries in the list

Subclipse plugin

4. Uncheck the option that says Contact all update sites during install to find required software and click Next

5. Click Next again, accept the license agreement and click Finish

6. When prompted for restart choose Yes

To learn how to use the Subclipse plugin follow the official Subclipse Guide (also found under Help > Help Contents in WireframeSketcher) or a more easier Using Subclipse guide.

Subversive plugin

Here are the steps that you need to follow to install Subversive plugin:

1. Enable Eclipse Luna update site in WireframeSketcher’s preferences under Window > Preferences > Install/Update > Available Software Sites:

Enable Luna update site

Make sure that the Luna entry is checked.

2. Open Help > Install New Software… wizard, select Luna in Work with field and then wait for the software list to load and the Pending… message to disappear.

3. Type SVN in the type filter text search field and wait for the software list to change

4. Check the Subversive SVN Team Provider entry in the list

Subversion plugin

5. Uncheck the option that says Contact all update sites during install to find required software and click Next

6. Click Next again, accept the license agreement and click Finish

7. When prompted for restart choose Yes

8. After the restart you’ll be prompted to install a connector for SVN 1.7.x or 1.8.x . Depending on what you use choose either SVN Kit 1.7.x or SVN Kit 1.8.x and click Finish. It can happen that the connectors install prompt does not appear or you’ve dismissed it when it did. In this case you can install the required connector manually as follows:

8.1. Open Help > Install New Software… again and paste the following update site link in Work with field and press Enter:
http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/

8.2. Check the Subversive SVN Connectors entry and the desired version of SVN Kit in the list and click Next

Subversive Connectors

9. Go through the installation steps, accept the security warning prompt and choose to restart at the end

To learn how to use the Subversive plugin read Subversive Tutorial or go through the more extensive Subversive User Guide.

Uninstalling

To uninstall the Subversion plugin select Help > About WireframeSketcher > Installation Details then choose Subclipse or Subversive plugin and click Uninstall… and then Finish.