Installing Mercurial plugin

This is a step by step guide on how to add support for Mercurial version control system and enable team collaboration directly in WireframeSketcher. This is done by installing the free MercurialEclipse Eclipse plug-in.

Installing

Follow these steps to install the MercurialEclipse plugin:

1. Open Help > Install New Software… wizard, and paste the following update site link into Work with field and press Enter. Wait for the software list to load and the Pending… message to disappear.
http://mercurialeclipse.eclipselabs.org.codespot.com/hg.wiki/update_site/stable

2. Check the MercurialEclipse entry in the list

MercurialEclipse plugin

3. Uncheck the option that says Contact all update sites during install to find required software and click Next

4. Click Next again, accept the license agreement and click Finish

5. When prompted for restart choose Yes

To learn how to use the MercurialEclipse plugin follow the MercurialEclipse Wiki. MercurialEclipse requires the Mercurial client (hg) to be pre-installed on your system. Refer to Mercurial website for more details on that.

Note that to connect to a MercurialEclipse server you’ll need to switch to Mercurial perspective first using Window > Open Perspective > Other… > Mercurial Repository Exploring. To switch back to Wireframing perspective use Window > Open Perspective > Other… > Wireframing.

Uninstalling

To uninstall the MercurialEclipse plugin select Help > About WireframeSketcher > Installation Details then choose MercurialEclipse and click Uninstall… and then Finish.